import re
regex = re.compile(r"^((((0?[1-9])|([1,2][0-9])|3[0,1])\.((0?[1,3,5,7,8])|10|12))|(((0?[1-9])|([1,2][0-9])|30)\.((0?[2,4,6,9])|11)))\.[0-9]{4}$", flags=re.MULTILINE)
test_str = ("31.05.2020\n"
"01.01.2020")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")