// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((((0?[1-9])|([1,2][0-9])|3[0,1])\.((0?[1,3,5,7,8])|10|12))|(((0?[1-9])|([1,2][0-9])|30)\.((0?[2,4,6,9])|11)))\.[0-9]{4}$").unwrap();
let string = "31.05.2020
01.01.2020";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}