re = /^((((0?[1-9])|([1,2][0-9])|3[0,1])\.((0?[1,3,5,7,8])|10|12))|(((0?[1-9])|([1,2][0-9])|30)\.((0?[2,4,6,9])|11)))\.[0-9]{4}$/m
str = '31.05.2020
01.01.2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end