using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((((0?[1-9])|([1,2][0-9])|3[0,1])\.((0?[1,3,5,7,8])|10|12))|(((0?[1-9])|([1,2][0-9])|30)\.((0?[2,4,6,9])|11)))\.[0-9]{4}$";
string input = @"31.05.2020
01.01.2020";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}