#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\d.(.*?)(journorequests\.com){1}"
Local $sString = "- Health & Fitness --- 1. Phee Waterfield (https://www.twitter.com/pheecetious) Does anyone know of any mental health accelerators or incubators? #journorequest #techjpr #prrequest **https://**www.journorequests.com/redirect… & Fitness&url=https%3A%2F%2Fwww.twitter.com%2Fpheecetious%2Fstatus%2F920331054342463488&medium=instant_alert"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")