$re = '/^.*?\d.(.*?)(journorequests\.com){1}/m';
$str = '- Health & Fitness --- 1. Phee Waterfield (https://www.twitter.com/pheecetious) Does anyone know of any mental health accelerators or incubators? #journorequest #techjpr #prrequest **https://**www.journorequests.com/redirect… & Fitness&url=https%3A%2F%2Fwww.twitter.com%2Fpheecetious%2Fstatus%2F920331054342463488&medium=instant_alert';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);