using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\d.(.*?)(journorequests\.com){1}";
string input = @"- Health & Fitness --- 1. Phee Waterfield (https://www.twitter.com/pheecetious) Does anyone know of any mental health accelerators or incubators? #journorequest #techjpr #prrequest **https://**www.journorequests.com/redirect… & Fitness&url=https%3A%2F%2Fwww.twitter.com%2Fpheecetious%2Fstatus%2F920331054342463488&medium=instant_alert";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}