import Foundation
let pattern = #"^.*?\d.(.*?)(journorequests\.com){1}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"- Health & Fitness --- 1. Phee Waterfield (https://www.twitter.com/pheecetious) Does anyone know of any mental health accelerators or incubators? #journorequest #techjpr #prrequest **https://**www.journorequests.com/redirect… & Fitness&url=https%3A%2F%2Fwww.twitter.com%2Fpheecetious%2Fstatus%2F920331054342463488&medium=instant_alert"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)