// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?\d.(.*?)(journorequests\.com){1}").unwrap();
let string = "- Health & Fitness --- 1. Phee Waterfield (https://www.twitter.com/pheecetious) Does anyone know of any mental health accelerators or incubators? #journorequest #techjpr #prrequest **https://**www.journorequests.com/redirect… & Fitness&url=https%3A%2F%2Fwww.twitter.com%2Fpheecetious%2Fstatus%2F920331054342463488&medium=instant_alert";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}