#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(.*\.net)[^\?#]*(.*)"
Local $sString = "https://apfelschuss.azureedge.net"
Local $sSubst = "$1/index.html$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)