re = /(.*\.net)[^\?#]*(.*)/im
str = 'https://apfelschuss.azureedge.net'
subst = '$1/index.html$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result