use strict;
my $str = 'https://apfelschuss.azureedge.net';
my $regex = qr/(.*\.net)[^\?#]*(.*)/imp;
my $subst = '$1/index.html$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";