const regex = new RegExp('(.*\\.net)[^\\?#]*(.*)', 'im')
const str = `https://apfelschuss.azureedge.net`;
const subst = `$1/index.html$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);