# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+((?<=Colombo: ).+)[\s|\S]+((?<=TestL: ).+)[\s|\S]+((?<=Restric: ).+)/$2:$3@$1/gm;t' <<< "Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
"