using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+((?<=Colombo: ).+)[\s|\S]+((?<=TestL: ).+)[\s|\S]+((?<=Restric: ).+)";
string substitution = @"$2:$3@$1";
string input = @"Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}