$re = '/.+((?<=Colombo: ).+)[\s|\S]+((?<=TestL: ).+)[\s|\S]+((?<=Restric: ).+)/m';
$str = 'Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
';
$subst = "$2:$3@$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;