import re
regex = re.compile(r".+((?<=Colombo: ).+)[\s|\S]+((?<=TestL: ).+)[\s|\S]+((?<=Restric: ).+)", flags=re.MULTILINE)
test_str = ("Colombo: tentio.milenium:02\n"
"TestL: u29kae.ee\n"
"Restric: free28os\n")
subst = "$2:$3@$1"
result = regex.sub(subst, test_str)
if result:
print(result)