package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@.+k\s[[].+[\][msg:\s"].+"[\]]`)
var str = `@block [user][msg:
"you messagnbb"]
nnbb @block [hello][msg:"no"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}