import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@.+k\\s[[].+[\\][msg:\\s\"].+\"[\\]]";
final String string = "@block [user][msg:\n"
+ "\"you messagnbb\"]\n\n"
+ "nnbb @block [hello][msg:\"no\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}