$re = '/@.+k\s[[].+[\][msg:\s"].+"[\]]/i';
$str = '@block [user][msg:
"you messagnbb"]
nnbb @block [hello][msg:"no"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);