re = /@.+k\s[[].+[\][msg:\s"].+"[\]]/i
str = '@block [user][msg:
"you messagnbb"]
nnbb @block [hello][msg:"no"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end