#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\s#).{3,}(?<!md\))$"
Local $sString = " # Containers" & @CRLF & _
"I am the content" & @CRLF & _
"" & @CRLF & _
"[Client Facing](Containers/Client%20Facing.md)" & @CRLF & _
"" & @CRLF & _
"[API](Containers/API.md)" & @CRLF & _
"" & @CRLF & _
"[Backend Services](Containers/Backend%20Services.md)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")