import re
regex = re.compile(r"^(?!\s#).{3,}(?<!md\))$", flags=re.MULTILINE)
test_str = (" # Containers\n"
"I am the content\n\n"
"[Client Facing](Containers/Client%20Facing.md)\n\n"
"[API](Containers/API.md)\n\n"
"[Backend Services](Containers/Backend%20Services.md)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")