$re = '/^(?!\s#).{3,}(?<!md\))$/m';
$str = ' # Containers
I am the content
[Client Facing](Containers/Client%20Facing.md)
[API](Containers/API.md)
[Backend Services](Containers/Backend%20Services.md)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);