re = /^(?!\s#).{3,}(?<!md\))$/m
str = ' # Containers
I am the content
[Client Facing](Containers/Client%20Facing.md)
[API](Containers/API.md)
[Backend Services](Containers/Backend%20Services.md)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end