import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s#).{3,}(?<!md\\))$";
final String string = " # Containers\n"
+ "I am the content\n\n"
+ "[Client Facing](Containers/Client%20Facing.md)\n\n"
+ "[API](Containers/API.md)\n\n"
+ "[Backend Services](Containers/Backend%20Services.md)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}