import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=start~)(.+)(?=~end)";
final String string = "http://localhost:3000/#/reconciliation/historyRecord/list?cr-dz=start~type=0&result=&hospitalId=123&reconciliationStartDate=2021-05-05%2000%3A00%3A00&reconciliationEndDate=2021-05-05%2000%3A00%3A00&ifPage=true&page=1&limit=10~end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}