import Foundation
let pattern = #"(?<=start~)(.+)(?=~end)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"http://localhost:3000/#/reconciliation/historyRecord/list?cr-dz=start~type=0&result=&hospitalId=123&reconciliationStartDate=2021-05-05%2000%3A00%3A00&reconciliationEndDate=2021-05-05%2000%3A00%3A00&ifPage=true&page=1&limit=10~end"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)