import re
regex = re.compile(r"(?<=start~)(.+)(?=~end)", flags=re.MULTILINE)
test_str = "http://localhost:3000/#/reconciliation/historyRecord/list?cr-dz=start~type=0&result=&hospitalId=123&reconciliationStartDate=2021-05-05%2000%3A00%3A00&reconciliationEndDate=2021-05-05%2000%3A00%3A00&ifPage=true&page=1&limit=10~end"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")