const regex = /(?<=start~)(.+)(?=~end)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=start~)(.+)(?=~end)', 'gm')
const str = `http://localhost:3000/#/reconciliation/historyRecord/list?cr-dz=start~type=0&result=&hospitalId=123&reconciliationStartDate=2021-05-05%2000%3A00%3A00&reconciliationEndDate=2021-05-05%2000%3A00%3A00&ifPage=true&page=1&limit=10~end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}