using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\.\d{2})\d+$";
string substitution = @"$1";
string input = @"6.933141
5.13
1.56
2.94
1.54
6.470931";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}