$re = '/^(\d+\.\d{2})\d+$/m';
$str = '6.933141
5.13
1.56
2.94
1.54
6.470931';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;