#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^| )text($| )"
Local $sString = " text .text. 'text' " & @CRLF & _
"text .text. 'text' " & @CRLF & _
"text .text. text 'text' " & @CRLF & _
" text .text. text 'text' text" & @CRLF & _
"text .text. text 'text'text" & @CRLF & _
" text " & @CRLF & _
" text" & @CRLF & _
"text" & @CRLF & _
" edittext stext" & @CRLF & _
"edittext stext " & @CRLF & _
" textedit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")