$re = '/(^| )text($| )/m';
$str = ' text .text. \'text\'
text .text. \'text\'
text .text. text \'text\'
text .text. text \'text\' text
text .text. text \'text\'text
text
text
text
edittext stext
edittext stext
textedit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);