import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^| )text($| )";
final String string = " text .text. 'text' \n"
+ "text .text. 'text' \n"
+ "text .text. text 'text' \n"
+ " text .text. text 'text' text\n"
+ "text .text. text 'text'text\n"
+ " text \n"
+ " text\n"
+ "text\n"
+ " edittext stext\n"
+ "edittext stext \n"
+ " textedit";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}