re = /(^| )text($| )/m
str = ' text .text. \'text\'
text .text. \'text\'
text .text. text \'text\'
text .text. text \'text\' text
text .text. text \'text\'text
text
text
text
edittext stext
edittext stext
textedit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end