#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?us)<span\b[^>]*+>(?# Открывающий span с любыми атребутами" & @CRLF & _
" )\s*+(?# Пробелы" & @CRLF & _
" )(?<number>\-?+\d++(?:[\.\,]\d++)?+)(?# Число" & @CRLF & _
" )\s*+(?# Пробелы" & @CRLF & _
")<\/span>(?# Закрывающий span)"
Local $sString = "<span class="company__segment__inner">0</span>" & @CRLF & _
"<span class="company__segment__inner">1</span>" & @CRLF & _
"<span class="company__segment__inner">1.</span>" & @CRLF & _
"<span class="company__segment__inner">1.0</span>" & @CRLF & _
"<span class="company__segment__inner">-1</span>" & @CRLF & _
"<span class="company__segment__inner">12121.12212</span>" & @CRLF & _
"<span class="company__segment__inner">192.168.0.1</span>" & @CRLF & _
"<span class="company__segment__inner">Только числа</span>" & @CRLF & _
"<span>1</span>" & @CRLF & _
"<spank>1</spank>" & @CRLF & _
"<span>-0,123</span>" & @CRLF & _
"<span>" & @CRLF & _
" -0,123" & @CRLF & _
" </span>"
Local $sSubst = "${number}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)