use strict;
my $str = '<span class="company__segment__inner">0</span>
<span class="company__segment__inner">1</span>
<span class="company__segment__inner">1.</span>
<span class="company__segment__inner">1.0</span>
<span class="company__segment__inner">-1</span>
<span class="company__segment__inner">12121.12212</span>
<span class="company__segment__inner">192.168.0.1</span>
<span class="company__segment__inner">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>';
my $regex = qr/<span\b[^>]*+>(?# Открывающий span с любыми атребутами
)\s*+(?# Пробелы
)(?<number>\-?+\d++(?:[\.\,]\d++)?+)(?# Число
)\s*+(?# Пробелы
)<\/span>(?# Закрывающий span)/usp;
my $subst = '${number}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";