// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?us)<span\b[^>]*+>(?# Открывающий span с любыми атребутами
)\s*+(?# Пробелы
)(?<number>\-?+\d++(?:[\.\,]\d++)?+)(?# Число
)\s*+(?# Пробелы
)<\/span>(?# Закрывающий span)").unwrap();
let string = "<span class=\"company__segment__inner\">0</span>
<span class=\"company__segment__inner\">1</span>
<span class=\"company__segment__inner\">1.</span>
<span class=\"company__segment__inner\">1.0</span>
<span class=\"company__segment__inner\">-1</span>
<span class=\"company__segment__inner\">12121.12212</span>
<span class=\"company__segment__inner\">192.168.0.1</span>
<span class=\"company__segment__inner\">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>";
let substitution = "${number}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}