using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span\b[^>]*+>(?# Открывающий span с любыми атребутами
)\s*+(?# Пробелы
)(?<number>\-?+\d++(?:[\.\,]\d++)?+)(?# Число
)\s*+(?# Пробелы
)<\/span>(?# Закрывающий span)";
string substitution = @"${number}";
string input = @"<span class=""company__segment__inner"">0</span>
<span class=""company__segment__inner"">1</span>
<span class=""company__segment__inner"">1.</span>
<span class=""company__segment__inner"">1.0</span>
<span class=""company__segment__inner"">-1</span>
<span class=""company__segment__inner"">12121.12212</span>
<span class=""company__segment__inner"">192.168.0.1</span>
<span class=""company__segment__inner"">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}