# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"<span\b[^>]*+>(?# Открывающий span с любыми атребутами\n"
r" )\s*+(?# Пробелы\n"
r" )(?<number>\-?+\d++(?:[\.\,]\d++)?+)(?# Число\n"
r" )\s*+(?# Пробелы\n"
r")<\/span>(?# Закрывающий span)")
test_str = ("<span class=\"company__segment__inner\">0</span>\n"
"<span class=\"company__segment__inner\">1</span>\n"
"<span class=\"company__segment__inner\">1.</span>\n"
"<span class=\"company__segment__inner\">1.0</span>\n"
"<span class=\"company__segment__inner\">-1</span>\n"
"<span class=\"company__segment__inner\">12121.12212</span>\n"
"<span class=\"company__segment__inner\">192.168.0.1</span>\n"
"<span class=\"company__segment__inner\">Только числа</span>\n"
"<span>1</span>\n"
"<spank>1</spank>\n"
"<span>-0,123</span>\n"
"<span>\n"
" -0,123\n"
" </span>")
subst = "${number}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.