package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\s*(to|-)\s*\d+\b\s*[a-zA-Z]+\/[a-zA-Z]+\/[a-z]+`)
var str = `I am trying to extract a math formula from a string; the pattern is almost the same.
GA 28-32 wks: 10 to 12 mm/kk/day, Q6-8h;
I want to extract the Bold text from the string. Another type from the string.
10-15 g/kg/week, Q6h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}