import Foundation
let pattern = #"\b\d+\s*(to|-)\s*\d+\b\s*[a-zA-Z]+\/[a-zA-Z]+\/[a-z]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I am trying to extract a math formula from a string; the pattern is almost the same.
GA 28-32 wks: 10 to 12 mm/kk/day, Q6-8h;
I want to extract the Bold text from the string. Another type from the string.
10-15 g/kg/week, Q6h
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)