const regex = /\b\d+\s*(to|-)\s*\d+\b\s*[a-zA-Z]+\/[a-zA-Z]+\/[a-z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\s*(to|-)\\s*\\d+\\b\\s*[a-zA-Z]+\\\/[a-zA-Z]+\\\/[a-z]+', 'gm')
const str = `I am trying to extract a math formula from a string; the pattern is almost the same.
GA 28-32 wks: 10 to 12 mm/kk/day, Q6-8h;
I want to extract the Bold text from the string. Another type from the string.
10-15 g/kg/week, Q6h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}