$re = '/\b\d+\s*(to|-)\s*\d+\b\s*[a-zA-Z]+\/[a-zA-Z]+\/[a-z]+/m';
$str = 'I am trying to extract a math formula from a string; the pattern is almost the same.
GA 28-32 wks: 10 to 12 mm/kk/day, Q6-8h;
I want to extract the Bold text from the string. Another type from the string.
10-15 g/kg/week, Q6h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);