use strict;
my $str = 'I am trying to extract a math formula from a string; the pattern is almost the same.
GA 28-32 wks: 10 to 12 mm/kk/day, Q6-8h;
I want to extract the Bold text from the string. Another type from the string.
10-15 g/kg/week, Q6h';
my $regex = qr/\b\d+\s*(to|-)\s*\d+\b\s*[a-zA-Z]+\/[a-zA-Z]+\/[a-z]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}