const regex = /\b0|([0-1])(?=0*~[0-1]*?\1([0-1]))|~[0-1]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0|([0-1])(?=0*~[0-1]*?\\1([0-1]))|~[0-1]*', 'g')
const str = `0101~010`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);