re = /\b0|([0-1])(?=0*~[0-1]*?\1([0-1]))|~[0-1]*/
str = '0101~010'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result