import Foundation
let pattern = #"\b0|([0-1])(?=0*~[0-1]*?\1([0-1]))|~[0-1]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0101~010"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)