use strict;
my $str = '0101~010';
my $regex = qr/\b0|([0-1])(?=0*~[0-1]*?\1([0-1]))|~[0-1]*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";